史萊姆論壇

返回   史萊姆論壇 > 教學文件資料庫 > 網路軟硬體架設技術文件
忘記密碼?
註冊帳號 論壇說明 標記討論區已讀

歡迎您來到『史萊姆論壇』 ^___^

您目前正以訪客的身份瀏覽本論壇,訪客所擁有的權限將受到限制,您可以瀏覽本論壇大部份的版區與文章,但您將無法參與任何討論或是使用私人訊息與其他會員交流。若您希望擁有完整的使用權限,請註冊成為我們的一份子,註冊的程序十分簡單、快速,而且最重要的是--註冊是完全免費的!

請點擊這裡:『註冊成為我們的一份子!』

Google 提供的廣告


 
 
主題工具 顯示模式
舊 2003-11-14, 06:57 PM   #1
aacced
註冊會員
 
aacced 的頭像
榮譽勳章

勳章總數
UID - 84058
在線等級: 級別:0 | 在線時長:0小時 | 升級還需:5小時
註冊日期: 2003-07-07
VIP期限: 2006-01
住址: 上帝禁區
文章: 193
精華: 0
現金: -11 金幣
資產: -11 金幣
預設 Cisco路由器的安全配置簡易方案

一,路由器訪問控制的安全配置
1,嚴格控制可以訪問路由器的管理員。任何一次維護都需要記錄備案。
2,建議不要遠程訪問路由器。即使需要遠程訪問路由器,建議使用訪問控制列表和高強度的密碼控制。
3,嚴格控制CON端口的訪問。具體的措施有:
A,如果可以開機箱的,則可以切斷與CON口互聯的物理線路。
B,可以改變默認的連接屬性,例如修改波特率(默認是96000,可以改為其他的)。
C,配合使用訪問控制列表控制對CON口的訪問。
如:Router(Config)#Access-list 1 permit 192.168.0.1
Router(Config)#line con 0
Router(Config-line)#Transport input none
Router(Config-line)#Login local
Router(Config-line)#Exec-timeoute 5 0
Router(Config-line)#access-class 1 in
Router(Config-line)#end
D,給CON口設置高強度的密碼。
4,如果不使用AUX端口,則禁止這個端口。默認是未被啟用。禁止如:
Router(Config)#line aux 0
Router(Config-line)#transport input none
Router(Config-line)#no exec
5,建議採用權限分級策略。如:
Router(Config)#username BluShin privilege 10 G00dPa55w0rd
Router(Config)#privilege EXEC level 10 telnet
Router(Config)#privilege EXEC level 10 show ip access-list
6,為特權模式的進入設置強壯的密碼。不要採用enable password設置密碼。而要採用enable secret命令設置。並且要啟用Service password-encryption。
7,控制對VTY的訪問。如果不需要遠程訪問則禁止它。如果需要則一定要設置強壯的密碼。由於VTY在網絡的傳輸過程中為加密,所以需要對其進行嚴格的控制。如:設置強壯的密碼;控制連接的並發數目;採用訪問列表嚴格控制訪問的地址;可以採用AAA設置用戶的訪問控制等。
8,IOS的升級和備份,以及配置文件的備份建議使用FTP代替TFTP。如:
Router(Config)#ip ftp username BluShin
Router(Config)#ip ftp password 4tppa55w0rd
Router#copy startup-config ftp:
9,及時的升級和修補IOS軟件。

二,路由器網絡服務安全配置
1,禁止CDP(Cisco Discovery Protocol)。如:
Router(Config)#no cdp run
Router(Config-if)# no cdp enable
2,禁止其他的TCP、UDP Small服務。
Router(Config)# no service tcp-small-servers
Router(Config)# no service udp-samll-servers
3,禁止Finger服務。
Router(Config)# no ip finger
Router(Config)# no service finger
4,建議禁止HTTP服務。
Router(Config)# no ip http server
如果啟用了HTTP服務則需要對其進行安全配置:設置用戶名和密碼;採用訪問列表進行控制。如:
Router(Config)# username BluShin privilege 10 G00dPa55w0rd
Router(Config)# ip http auth local
Router(Config)# no access-list 10
Router(Config)# access-list 10 permit 192.168.0.1
Router(Config)# access-list 10 deny any
Router(Config)# ip http access-class 10
Router(Config)# ip http server
Router(Config)# exit
5,禁止BOOTp服務。
Router(Config)# no ip bootp server
禁止從網絡啟動和自動從網絡下載初始配置文件。
Router(Config)# no boot network
Router(Config)# no servic config
6,禁止IP Source Routing。
Router(Config)# no ip source-route
7,建議如果不需要ARP-Proxy服務則禁止它,路由器默認識開啟的。
Router(Config)# no ip proxy-arp
Router(Config-if)# no ip proxy-arp
8,明確的禁止IP Directed Broadcast。
Router(Config)# no ip directed-broadcast
9,禁止IP Classless。
Router(Config)# no ip classless
10,禁止ICMP協議的IP Unreachables,Redirects,Mask Replies。
Router(Config-if)# no ip unreacheables
Router(Config-if)# no ip redirects
Router(Config-if)# no ip mask-reply
11,建議禁止SNMP協議服務。在禁止時必須刪除一些SNMP服務的默認配置。或者需要訪問列表來過濾。如:
Router(Config)# no snmp-server community public Ro
Router(Config)# no snmp-server community admin RW
Router(Config)# no access-list 70
Router(Config)# access-list 70 deny any
Router(Config)# snmp-server community MoreHardPublic Ro 70
Router(Config)# no snmp-server enable traps
Router(Config)# no snmp-server system-shutdown
Router(Config)# no snmp-server trap-anth
Router(Config)# no snmp-server
Router(Config)# end
12,如果沒必要則禁止WINS和DNS服務。
Router(Config)# no ip domain-lookup
如果需要則需要配置:
Router(Config)# hostname Router
Router(Config)# ip name-server 202.102.134.96
13,明確禁止不使用的端口。
Router(Config)# interface eth0/3
Router(Config)# shutdown

三,路由器路由協議安全配置
1,首先禁止默認啟用的ARP-Proxy,它容易引起路由表的混亂。
Router(Config)# no ip proxy-arp 或者
Router(Config-if)# no ip proxy-arp
2,啟用OSPF路由協議的認證。默認的OSPF認證密碼是明文傳輸的,建議啟用MD5認證。並設置一定強度密鑰(key,相對的路由器必須有相同的Key)。
Router(Config)# router ospf 100
Router(Config-router)# network 192.168.100.0 0.0.0.255 area 100
! 啟用MD5認證。
! area area-id authentication 啟用認證,是明文密碼認證。
!area area-id authentication message-digest
Router(Config-router)# area 100 authentication message-digest
Router(Config)# exit
Router(Config)# interface eth0/1
!啟用MD5密鑰Key為routerospfkey。
!ip ospf authentication-key key 啟用認證密鑰,但會是明文傳輸。
!ip ospf message-digest-key key-id(1-255) md5 key
Router(Config-if)# ip ospf message-digest-key 1 md5 routerospfkey
3,RIP協議的認證。只有RIP-V2支持,RIP-1不支持。建議啟用RIP-V2。並且採用MD5認證。普通認證同樣是明文傳輸的。
Router(Config)# config terminal
! 啟用設置密鑰鏈
Router(Config)# key chain mykeychainname
Router(Config-keychain)# key 1
!設置密鑰字串
Router(Config-leychain-key)# key-string MyFirstKeyString
Router(Config-keyschain)# key 2
Router(Config-keychain-key)# key-string MySecondKeyString
!啟用RIP-V2
Router(Config)# router rip
Router(Config-router)# version 2
Router(Config-router)# network 192.168.100.0
Router(Config)# interface eth0/1
! 採用MD5模式認證,並選擇已配置的密鑰鏈
Router(Config-if)# ip rip authentication mode md5
Router(Config-if)# ip rip anthentication key-chain mykeychainname
4,啟用passive-interface命令可以禁用一些不需要接收和轉發路由信息的端口。建議對於不需要路由的端口,啟用passive-interface。但是,在RIP協議是只是禁止轉發路由信息,並沒有禁止接收。在OSPF協議中是禁止轉發和接收路由信息。
! Rip中,禁止端口0/3轉發路由信息
Router(Config)# router Rip
Router(Config-router)# passive-interface eth0/3
!OSPF中,禁止端口0/3接收和轉發路由信息
Router(Config)# router ospf 100
Router(Config-router)# passive-interface eth0/3
5,啟用訪問列表過濾一些垃圾和惡意路由信息,控制網絡的垃圾信息流。
Router(Config)# access-list 10 deny 192.168.1.0 0.0.0.255
Router(Config)# access-list 10 permit any
! 禁止路由器接收更新192.168.1.0網絡的路由信息
Router(Config)# router ospf 100
Router(Config-router)# distribute-list 10 in
!禁止路由器轉發傳播192.168.1.0網絡的路由信息
Router(Config)# router ospf 100
Router(Config-router)# distribute-list 10 out
6,建議啟用IP Unicast Reverse-Path Verification。它能夠檢查源IP地址的準確性,從而可以防止一定的IP Spooling。但是它只能在啟用CEF(Cisco Express Forwarding)的路由器上使用。
Router# config t
! 啟用CEF
Router(Config)# ip cef
!啟用Unicast Reverse-Path Verification
Router(Config)# interface eth0/1
Router(Config)# ip verify unicast reverse-path
四,路由器審核安全配置

五,路由器其他安全配置
1,及時的升級IOS軟件,並且要迅速的為IOS安裝補丁。
2,要嚴格認真的為IOS作安全備份。
3,要為路由器的配置文件作安全備份。
4,購買UPS設備,或者至少要有冗余電源。
5,要有完備的路由器的安全訪問和維護記錄日誌。
6,要嚴格設置登錄Banner。必須包含非授權用戶禁止登錄的字樣。
7,IP欺騙得簡單防護。如過濾非公有地址訪問內部網絡。過濾自己內部網絡地址;迴環地址(127.0.0.0/8);RFC1918私有地址;DHCP自定義地址(169.254.0.0/16);科學文檔作者測試用地址(192.0.2.0/24);不用的組播地址(224.0.0.0/4);SUN公司的古老的測試地址(20.20.20.0/24;204.152.64.0/23);全網絡地址(0.0.0.0/8)。
Router(Config)# access-list 100 deny ip 192.168.0.0 0.0.0.255 any log
Router(Config)# access-list 100 deny ip 127.0.0.0 0.255.255.255 any log
Router(Config)# access-list 100 deny ip 192.168.0.0 0.0.255.255 any log
Router(Config)# access-list 100 deny ip 172.16.0.0 0.15.255.255 any log
Router(Config)# access-list 100 deny ip 10.0.0.0 0.255.255.255 any log
Router(Config)# access-list 100 deny ip 169.254.0.0 0.0.255.255 any log
Router(Config)# access-list 100 deny ip 192.0.2.0 0.0.0.255 any log
Router(Config)# access-list 100 deny ip 224.0.0.0 15.255.255.255 any
Router(Config)# access-list 100 deny ip 20.20.20.0 0.0.0.255 any log
Router(Config)# access-list 100 deny ip 204.152.64.0 0.0.2.255 any log
Router(Config)# access-list 100 deny ip 0.0.0.0 0.255.255.255 any log
8,建議採用訪問列表控制流出內部網絡的地址必須是屬於內部網絡的。如:
Router(Config)# no access-list 101
Router(Config)# access-list 101 permit ip 192.168.0.0 0.0.0.255 any
Router(Config)# access-list 101 deny ip any any log
Router(Config)# interface eth 0/1
Router(Config-if)# description 「internet Ethernet」
Router(Config-if)# ip address 192.168.0.254 255.255.255.0
Router(Config-if)# ip access-group 101 in
9,TCP SYN的防範。如:
A: 通過訪問列表防範。
Router(Config)# no access-list 106
Router(Config)# access-list 106 permit tcp any 192.168.0.0 0.0.0.255 established
Router(Config)# access-list 106 deny ip any any log
Router(Config)# interface eth 0/2
Router(Config-if)# description 「external Ethernet」
Router(Config-if)# ip address 192.168.1.254 255.255.255.0
Router(Config-if)# ip access-group 106 in
B:通過TCP截獲防範。(這會給路由器產生一定負載)
Router(Config)# ip tcp intercept list 107
Router(Config)# access-list 107 permit tcp any 192.168.0.0 0.0.0.255
Router(Config)# access-list 107 deny ip any any log
Router(Config)# interface eth0
Router(Config)# ip access-group 107 in
10,LAND.C 進攻的防範。
Router(Config)# access-list 107 deny ip host 192.168.1.254 host 192.168.1.254 log
Router(Config)# access-list permit ip any any
Router(Config)# interface eth 0/2
Router(Config-if)# ip address 192.168.1.254 255.255.255.0
Router(Config-if)# ip access-group 107 in
11,Smurf進攻的防範。
Router(Config)# access-list 108 deny ip any host 192.168.1.255 log
Router(Config)# access-list 108 deny ip any host 192.168.1.0 log
12,ICMP協議的安全配置。對於進入ICMP流,我們要禁止ICMP協議的ECHO、Redirect、Mask request。也需要禁止TraceRoute命令的探測。對於流出的ICMP流,我們可以允許ECHO、Parameter Problem、Packet too big。還有TraceRoute命令的使用。
! outbound ICMP Control
Router(Config)# access-list 110 deny icmp any any echo log
Router(Config)# access-list 110 deny icmp any any redirect log
Router(Config)# access-list 110 deny icmp any any mask-request log
Router(Config)# access-list 110 permit icmp any any
! Inbound ICMP Control
Router(Config)# access-list 111 permit icmp any any echo
Router(Config)# access-list 111 permit icmp any any Parameter-problem
Router(Config)# access-list 111 permit icmp any any packet-too-big
Router(Config)# access-list 111 permit icmp any any source-quench
Router(Config)# access-list 111 deny icmp any any log
! Outbound TraceRoute Control
Router(Config)# access-list 112 deny udp any any range 33400 34400
! Inbound TraceRoute Control
Router(Config)# access-list 112 permit udp any any range 33400 34400
13,DDoS(Distributed Denial of Service)的防範。
! The TRINOO DDoS system
Router(Config)# access-list 113 deny tcp any any eq 27665 log
Router(Config)# access-list 113 deny udp any any eq 31335 log
Router(Config)# access-list 113 deny udp any any eq 27444 log
! The Stacheldtraht DDoS system
Router(Config)# access-list 113 deny tcp any any eq 16660 log
Router(Config)# access-list 113 deny tcp any any eq 65000 log
! The TrinityV3 System
Router(Config)# access-list 113 deny tcp any any eq 33270 log
Router(Config)# access-list 113 deny tcp any any eq 39168 log
! The SubSeven DDoS system and some Variants
Router(Config)# access-list 113 deny tcp any any range 6711 6712 log
Router(Config)# access-list 113 deny tcp any any eq 6776 log
Router(Config)# access-list 113 deny tcp any any eq 6669 log
Router(Config)# access-list 113 deny tcp any any eq 2222 log
Router(Config)# access-list 113 deny tcp any any eq 7000 log
13,建議啟用SSH,廢棄掉Telnet。但只有支持並帶有IPSec特徵集的IOS才支持SSH。並且IOS12.0-IOS12.2僅支持SSH-V1。如下配置SSH服務的例子:
Router(Config)# config t
Router(Config)# no access-list 22
Router(Config)# access-list 22 permit 192.168.0.22
Router(Config)# access-list deny any
Router(Config)# username BluShin privilege 10 G00dPa55w0rd
! 設置SSH的超時間隔和嘗試登錄次數
Router(Config)# ip ssh timeout 90
Router(Config)# ip ssh anthentication-retries 2
Router(Config)# line vty 0 4
Router(Config-line)# access-class 22 in
Router(Config-line)# transport input ssh
Router(Config-line)# login local
Router(Config-line)# exit
!啟用SSH服務,生成RSA密鑰對。
Router(Config)# crypto key generate rsa
The name for the keys will be: router.blushin.org
Choose the size of the key modulus in the range of 360 to 2048 for your General Purpose Keys .Choosing a key modulus greater than 512 may take a few minutes.
How many bits in the modulus[512]: 2048
Generating RSA Keys...
[OK]
Router(Config)#
六,路由器高級安全配置
附:路由器安全配置模板(略)
aacced 目前離線  
送花文章: 0, 收花文章: 0 篇, 收花: 0 次
 


主題工具
顯示模式

發表規則
不可以發文
不可以回覆主題
不可以上傳附加檔案
不可以編輯您的文章

論壇啟用 BB 語法
論壇啟用 表情符號
論壇啟用 [IMG] 語法
論壇禁用 HTML 語法
Trackbacks are 禁用
Pingbacks are 禁用
Refbacks are 禁用


所有時間均為台北時間。現在的時間是 09:56 AM


Powered by vBulletin® 版本 3.6.8
版權所有 ©2000 - 2020, Jelsoft Enterprises Ltd.


SEO by vBSEO 3.6.1